summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..dfe1752
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,20 @@
+{
+ description = "A BSD utility to generate random passwords suitable for handwriting";
+
+ inputs = {
+ nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
+ flake-utils.url = "github:numtide/flake-utils";
+ };
+
+ outputs = { self, nixpkgs, flake-utils }:
+ flake-utils.lib.eachDefaultSystem (system:
+ let pkgs = nixpkgs.legacyPackages.${system};
+ in {
+ overlays.default = import ./overlay.nix;
+ packages = {
+ jotpass = pkgs.callPackage ./jotpass.nix {};
+ default = self.packages.${system}.jotpass;
+ };
+ }
+ );
+}
Generated by cgit. See skreutz.com for my tech blog and contact information.