summaryrefslogtreecommitdiff
path: root/wpa-psk/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'wpa-psk/Cargo.toml')
-rw-r--r--wpa-psk/Cargo.toml17
1 files changed, 17 insertions, 0 deletions
diff --git a/wpa-psk/Cargo.toml b/wpa-psk/Cargo.toml
new file mode 100644
index 0000000..ca173f4
--- /dev/null
+++ b/wpa-psk/Cargo.toml
@@ -0,0 +1,17 @@
+[package]
+name = "wpa-psk"
+version = "0.2.0"
+authors = ["Stefan Kreutz <mail@skreutz.com>"]
+edition = "2021"
+description = "Compute the WPA-PSK of a Wi-FI SSID and passphrase"
+readme = "README.md"
+repository = "https://www.skreutz.com/scm/git/wpa-psk.git"
+license = "MIT OR Apache-2.0"
+keywords = ["wifi", "wpa", "password", "hash"]
+categories = ["algorithms"]
+publish = true
+
+[dependencies]
+pbkdf2 = { version = "0.11.0", default-features = false }
+hmac = { version = "0.12.1", default-features = false }
+sha-1 = { version = "0.10.0", default-features = false }
Generated by cgit. See skreutz.com for my tech blog and contact information.