summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml20
1 files changed, 20 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..2987092
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,20 @@
+[package]
+name = "wpa-psk"
+version = "0.1.0"
+authors = ["Stefan Kreutz <mail@skreutz.com>"]
+edition = "2021"
+description = "Compute the WPA-PSK of a Wi-FI SSID and passphrase"
+readme = "README.md"
+repository = "https://www.skreutz.com/repos/wpa-psk-rs.git"
+license = "MIT OR Apache-2.0"
+keywords = ["wifi", "wpa", "password", "hash"]
+categories = ["command-line-utilities", "algorithms"]
+publish = true
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+pbkdf2 = { version = "0.10.0", default-features = false }
+hmac = { version = "0.12.0", default-features = false }
+sha-1 = { version = "0.10.0", default-features = false }
+clap = { version = "3.0.0-rc.11", features = ["derive"] }
Generated by cgit. See skreutz.com for my tech blog and contact information.