summaryrefslogtreecommitdiff
path: root/wpa-psk-cli/Cargo.toml
diff options
context:
space:
mode:
authorStefan Kreutz <mail@skreutz.com>2023-05-18 21:56:36 +0200
committerStefan Kreutz <mail@skreutz.com>2023-05-18 21:56:36 +0200
commitbe6e70ffde1ef213166b19330cf9418f9bad2f3b (patch)
tree50b41659573041fae9c135858417ee8989df505d /wpa-psk-cli/Cargo.toml
parent49f0bc6c310751b11cf72e893858ca19e9a2e9a4 (diff)
downloadwpa-psk-be6e70ffde1ef213166b19330cf9418f9bad2f3b.tar
Use clap without wrap_help feature
With the wrap_help feature, clap tries to determine the terminal width using the terminal-size crate. This involves access to the temporary directory, violating the stdio pledge on OpenBSD and thus aborting the process. This commit disables clap's wrap_help feature to keep the simple stdio pledge. Another solution could to pledge stdio and tmppath.
Diffstat (limited to 'wpa-psk-cli/Cargo.toml')
-rw-r--r--wpa-psk-cli/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/wpa-psk-cli/Cargo.toml b/wpa-psk-cli/Cargo.toml
index 4e1309f..a59ee2b 100644
--- a/wpa-psk-cli/Cargo.toml
+++ b/wpa-psk-cli/Cargo.toml
@@ -12,7 +12,7 @@ categories = ["command-line-utilities"]
publish = true
[dependencies]
-clap = { version = "4.2.7", features = ["derive", "wrap_help"] }
+clap = { version = "4.2.7", features = ["derive"] }
wpa-psk = { path = "../wpa-psk", version = "0.2.2" }
[target.'cfg(target_os = "openbsd")'.dependencies]
Generated by cgit. See skreutz.com for my tech blog and contact information.