summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorStefan Kreutz <mail@skreutz.com>2022-05-28 15:15:39 +0200
committerStefan Kreutz <mail@skreutz.com>2022-05-28 15:15:39 +0200
commit988c7921eacee0cf0b519788c143fe428972b0dc (patch)
tree960de0b9d552c6b8dc28475acc0276ec66ae8e5f /Cargo.toml
parent7b9bff64d6c13cc8ea592c2ef6fec96d7062f0c5 (diff)
downloadwpa-psk-988c7921eacee0cf0b519788c143fe428972b0dc.tar
Extract wpa-psk-cli cratewpa-psk-cli-0.1.0wpa-psk-0.2.0
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml28
1 files changed, 5 insertions, 23 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 6480261..47db587 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,23 +1,5 @@
-[package]
-name = "wpa-psk"
-version = "0.1.5"
-authors = ["Stefan Kreutz <mail@skreutz.com>"]
-edition = "2021"
-description = "Compute the WPA-PSK of a Wi-FI SSID and passphrase"
-readme = "README.md"
-repository = "https://www.skreutz.com/scm/git/wpa-psk.git"
-license = "MIT OR Apache-2.0"
-keywords = ["wifi", "wpa", "password", "hash"]
-categories = ["command-line-utilities", "algorithms"]
-publish = true
-
-# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
-
-[dependencies]
-pbkdf2 = { version = "0.11.0", default-features = false }
-hmac = { version = "0.12.1", default-features = false }
-sha-1 = { version = "0.10.0", default-features = false }
-clap = { version = "3.1.18", features = ["derive"] }
-
-[dev-dependencies]
-assert_cmd = "2.0.4"
+[workspace]
+members = [
+ "wpa-psk",
+ "wpa-psk-cli",
+]
Generated by cgit. See skreutz.com for my tech blog and contact information.