diff options
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 25 |
1 files changed, 12 insertions, 13 deletions
@@ -1,21 +1,20 @@ -# Derived from https://github.com/ryantm/agenix/blob/1381a759b205dff7a6818733118d02253340fd5e/flake.nix - { description = "A temporary PostgreSQL server"; inputs = { nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable"; - systems.url = "github:nix-systems/default"; + flake-utils.url = "github:numtide/flake-utils"; }; - outputs = { self, nixpkgs, systems }: - let - eachSystem = nixpkgs.lib.genAttrs (import systems); - in { - overlays.default = import ./overlay.nix; - packages = eachSystem (system: { - temp-postgres = nixpkgs.legacyPackages.${system}.callPackage ./temp-postgres.nix {}; - default = self.packages.${system}.temp-postgres; - }); - }; + outputs = { self, nixpkgs, flake-utils }: + flake-utils.lib.eachDefaultSystem (system: + let pkgs = nixpkgs.legacyPackages.${system}; + in { + overlays.default = import ./overlay.nix; + packages = { + temp-postgres = pkgs.callPackage ./temp-postgres.nix {}; + default = self.packages.${system}.temp-postgres; + }; + } + ); } |