summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..386b141
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,21 @@
+# Derived from https://github.com/ryantm/agenix/blob/1381a759b205dff7a6818733118d02253340fd5e/flake.nix
+
+{
+ description = "A temporary PostgreSQL server";
+
+ inputs = {
+ nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
+ systems.url = "github:nix-systems/default";
+ };
+
+ outputs = { self, nixpkgs, systems }:
+ let
+ eachSystem = nixpkgs.lib.genAttrs (import systems);
+ in {
+ overlays.default = import ./overlay.nix;
+ packages = eachSystem (system: {
+ temp-postgres = nixpkgs.legacyPackages.${system}.callPackage ./temp-postgres.nix {};
+ default = self.packages.${system}.temp-postgres;
+ });
+ };
+}
Generated by cgit. See skreutz.com for my tech blog and contact information.