summaryrefslogtreecommitdiff
path: root/temp-postgres.nix
diff options
context:
space:
mode:
authorStefan Kreutz <mail@skreutz.com>2024-04-19 00:24:06 +0200
committerStefan Kreutz <mail@skreutz.com>2024-04-19 00:24:06 +0200
commit190906161db8120a58bdc4a2ac8138c4f3e45823 (patch)
tree2266f0f3764365c560339cb68bcbda3c24d6fe94 /temp-postgres.nix
parent0c1fea60db8075fe25bf68eb840a56ba9ce41069 (diff)
downloadtemp-postgres-190906161db8120a58bdc4a2ac8138c4f3e45823.tar
Add experimental flake.nix
Diffstat (limited to 'temp-postgres.nix')
-rw-r--r--temp-postgres.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/temp-postgres.nix b/temp-postgres.nix
new file mode 100644
index 0000000..3dc3338
--- /dev/null
+++ b/temp-postgres.nix
@@ -0,0 +1,23 @@
+{ lib, stdenv, postgresql, makeBinaryWrapper }:
+stdenv.mkDerivation rec {
+ name = "temp-postgres-${version}";
+ version = "0.1";
+
+ src = ./.;
+
+ nativeBuildInputs = [
+ makeBinaryWrapper
+ ];
+
+ buildInputs = [
+ postgresql
+ ];
+
+ installPhase = ''
+ mkdir -p $out/bin
+ cp temp-postgres.sh $out/bin/temp-postgres
+ mkdir -p $out/man/man1
+ cp temp-postgres.1 $out/man/man1/temp-postgres.1
+ wrapProgram $out/bin/temp-postgres --prefix PATH : ${lib.makeBinPath [ postgresql ]}
+ '';
+}
Generated by cgit. See skreutz.com for my tech blog and contact information.